POS & Inventory Control Systems

System Requirements

Booklog system requirements scale to meet stores of varying sizes from kiosks with one computer to large businesses with 30 client computers or more. Any Windows computer that meets the hardware requirements can function as a server or client.

Booklog version 10.0 and higher is compatible with all current and some legacy Windows operating systems.

What Versions of Windows will work with Booklog?

Booklog requires the Pro or Enterprise editions of Windows 7,8, or 10. Check your computers to make sure that they are running one of the following editions:

  • Windows 7 Pro
  • Windows 7 Enterprise
  • Windows 8 Pro
  • Windows 8 Enterprise
  • Windows 10 Pro
  • Windows 10 Enterprise

* 64 bit Windows is supported but not required.

 

What Versions of Windows will NOT work with Booklog?

The Home or Basic versions of Windows are limited in their business applications and will not allow some features to properly function. The following editions of Windows will not work with Booklog.

  • Windows 7 Starter, Windows 7 Home Basic, Windows 7 Home Premium
  • Windows 8 (Core), Windows RT
  • Windows 10 Home, Windows 10 Education, Windows 10 Mobile, Windows 10 Mobile Enterprise,
  • Windows 10 ioT Core

 

For further information, please contact tech@booklog.com or gwen@booklog.com.